cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

%100 CPU and Memory use due to McAfee

Jump to solution

So usually my Laptop is very fast, but in the past few months, it has been very slow, and whenever I go to the task manager to see what is causing it, there are TONS of McAfee processes, each taking up about one percent each, but they usually take up about %100 of the CPU and Memory use and they always go %100 and then drop own to about %50, then go up again, down again, up again, etc., etc., making my Laptop super laggy. I would reboot and it would fix he issue for a few days, but then it would just come back, and I am getting tired of it. Thanks.


Please note that I have had McAfee for many years and this has ever happened to me before.

CPU:

Intel Core i7 @ 2.50GHz

Haswell 22nm Technology

RAM:

8.00GB Single-Channel DDR3 @ 798MHz (11-11-11-28)

1 Solution

Accepted Solutions

Re: %100 CPU and Memory use due to McAfee

Jump to solution

I checked for updates to everything, and it turns out that my McAfee was quite out of date. Sorry.

View solution in original post

8 Replies

Re: %100 CPU and Memory use due to McAfee

Jump to solution

I moved this to the General Discussion area.

Check that your operating system is totally up to date, including any parts you may not use (IE for instance if you use another browser).

Check for any competing software and list them here in your reply.

Check Control Panel > Programs and Features to see if you've accidentally installed a sales promotional add-on called McAfee Security Scan Plus, it comes as an option with many other software downloads and could cause this.

Uninstall it if so.

Download and run the Virtual Technician here: https://mvt.mcafee.com/ to see if it finds and fixes any problems.

Hayton
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 9

Re: %100 CPU and Memory use due to McAfee

Jump to solution

Saying there are "tons of processes" in Task Manager doesn't help much in troubleshooting the problem. If the user posted a screenshot of those processes and stated what version of which McAfee product is running on the laptop, it might give you a better idea.

Re: %100 CPU and Memory use due to McAfee

Jump to solution

could you please indicate more details?   I am assuming you have Antivirus Plus as per your profile.  If that's the case then there will be quite a lot of McAfee items in Device Manager, however they shouldn't be causing 100% CPU usage.

Check for malware using other (free) software.

Run GetSusp and MalwareBytes Free from the last link below.

Note: read instructions carefully in order to install and use them correctly.

Anti-Spyware/Malware/Hijacker Tools

Re: %100 CPU and Memory use due to McAfee

Jump to solution

I checked for updates to everything, and it turns out that my McAfee was quite out of date. Sorry.

View solution in original post

Re: %100 CPU and Memory use due to McAfee

Jump to solution

So is it up to date now and the issue has not reoccurred or do you still need assistance?

helman
Level 7
Report Inappropriate Content
Message 7 of 9

Re: %100 CPU and Memory use due to McAfee

Jump to solution


I just created a Mcafee account to say to you THANK YOU!! I had my PC very slow because of that "McAfee Security Scan Plus". When I started the PC after it was being suspended, it lasted some minutes to react. Uninstalling it solved the issue!

Muratss
Level 7
Report Inappropriate Content
Message 8 of 9

Re: %100 CPU and Memory use due to McAfee

Jump to solution

I am using McAfee Live Save v16.0 R24 on Windows 10.

Unfortunately on some occasional time every day, Cloud AV service start working consuming relatively high CPU between %20-%60. Every time Scanner service start at the same time consuming the rest of the CPU. So, those two services block PC with %100 CPU for 30-60 minutes causing the PC dont respond and also warm up.

Can you please guide me to solution please. Regards.

Note. My laptop is Intel i7 8550 with 8GB of RAM and Nvidia Mx150.

Re: %100 CPU and Memory use due to McAfee

Jump to solution

I assume you checked that your McAfee Livesafe is up to date? That is my first suggestion.

Next would  be have you got any other AV installed or had one installed and did not use its own removal tool to remove it. Parts might be clashing with McAfee.

Final option  would be remove McAfee as per

How to remove McAfee

reboot after each part download and run the preinstall tool and reinstall the program.

Preinstall Tool

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community