cancel
Showing results for 
Search instead for 
Did you mean: 
BeemerBiker
Not applicable
Report Inappropriate Content
Message 1 of 2

Failed to initialize common updater, etc

googled and tried some stuff before I posted here.

Working System: Vista 64 home premium
Non working system: Vista 64 Ultimate

Neither system has that manifest xml file that supposidly can fix the problem
I cannot download it nor any code updates from mcafee as I am just a user
and not "macafee admin contact". I am admin on both systems and have
disabled that "user account control" that vista supports.

Did an uninstall and reinstall of 8.5 then tried patch 4

Tried registering all dll's in the x86 program file directory.
for %m in (*.dll) do regsvr32 /s %m
the above seemed to work even though I do not have write access to the following
C:\Program Files (x86)\McAfee\Common Framework
I removed the "/s" to verify that the dll's were indeed registered.
I do have write access to "McAfee" but not the subdirectory "Common Framework"
By "no write access" I mean I cannot put the batch file "fixreg.bat" in that directory. I can run the contents of the file by typing "for %m in (*.dll) do regsvr32 /s %m" but I cannot run that script from a batch file.

I got the following error messages associated with that "Failed to initialize common updater ..."

ffff?@? (failed to write it down but I remember the ffff) with 8.5 patch 1 then i uninstalled and then installed 8.5i but not the patch yet.

Got 8007076@2
after patch 4 went in I got 800706b5@3
I also ran that registration stuff a 2nd time after trying patch 4.

If someone can tell me what registery entries to save, I can export the registery entry from my Home Premium x64 system to the Business Ultimate x64 system.

If someone can email me that manifest xml file I would appreciate it. In the meantime I am downloading 5942xdat so i can get the latest and greatest.

thanks for looking

--update--
after I put in that 5942xdat file I got the error message 800700e@2
I can scan and do have the latest (Jun 10th) date and engine.
I had to run the sdat as "administrator" even tho UAC was disabled

---another update---
after rebooting I am back to error code fffff95b@2
1 Reply
Highlighted
BeemerBiker
Not applicable
Report Inappropriate Content
Message 2 of 2

solved

FrameworkManifest.xml was at "Program Data\McAfee", not at "Program Files .." my mistake

However, I want to thank whoever used their admin privilege to look up KB54520 and then left the answer in the google cache where I could find it.

I was able to do an update after porting over the good xml file and restarting the framework.
McAfee ePO Support Center Plug-in
Check out the new McAfee ePO Support Center. Simply access the ePO Software Manager and follow the instructions in the Product Guide for the most commonly used utilities, top known issues announcements, search the knowledgebase for product documentation, and server status and statistics – all from within ePO.