Showing results for 
Search instead for 
Did you mean: 
Level 7

Deployment of own package - failed, but OK on agent side


I have a problem of deploying own package to the client. We have ePO 5.1.1 with McAfee Agent 4.8.

I've created the package with EEDK 9.4 like this:

The deploy.bat should copy two files, and reboot the target machine. Here is the code:

@echo off
set log=c:\temp\McAfeeDeploy.log
echo. >>%log%
echo ----------------------------------- >> %log%
echo STARTED deploy.bat >> %log%
date /t >> %log%
time /t >> %log%

pushd "%~dp0"
for /f "delims=" %%a in ('cd') do @set SRCDIR=%%a
echo Current dir: %SRCDIR% >> %log%
echo. >> %log%

xcopy /y /f "%SRCDIR%\Shortcut to SimpleApp.exe.lnk" "c:\documents and settings\simpleuser\Start Menu\programs\Startup\" >> %log%
xcopy /y /f "%SRCDIR%\SimpleApp.exe" "c:\program files\Tools\" >> %log%

shutdown -r -f -c "McAfee deployment end, restart comes..." -t 20
echo FINISHED deploy.bat >> %log%
echo ----------------------------------- >> %log%
goto EOF

Exit /B 3010

On agent logs, I can see, that the deployment was OK:

Also, the c:\temp\McAfeeDeploy.log contains the successful installation.


STARTED deploy.bat



Current dir: C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Current\SYSAPPUD1008\Install\0000

C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Current\SYSAPPUD1008\Install\0000\Shortcut to ForceSysApp.exe.lnk -> C:\documents and settings\sstauto1\Start Menu\programs\Startup\Shortcut to ForceSysApp.exe.lnk

1 File(s) copied

C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Current\SYSAPPUD1008\Install\0000\ForceSysApp.exe -> C:\program files\NCR Aptra\Advance NDC\Tools\ForceSysApp.exe

1 File(s) copied

FINISHED deploy.bat


But from server task log says it failed:

I have no idea why it happens. If I check the result on the client, the agent says the truth. The install was successfully.

Anybody has an idea, how should I set the proper reply code from batch, that server should be notified about installation success?

Thanks in advance:


0 Kudos