cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 9
Report Inappropriate Content
Message 1 of 8

System Slowness with SC

Jump to solution

I have ePO with ENS and SC 8.1.1.143 in Windows setup.

All works fine but when I put SC in Observe or Enable mode, my custom application which heavily uses Graphics slows down. The application response is slow even in Observe mode is a bit surprising.

Any expert advice appreciated.

 

1 Solution

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: System Slowness with SC

Jump to solution

Hi @avilt,

Apologies for the delay, I was handling multiple sessions here! Quite the Weekend! Can you kindly please check if this helps you?

https://kc.mcafee.com/corporate/index?page=content&id=KB81465

Mostly we come across this to be the reason, struck me when you mentioned ENS is also being used! I sincerely hope this helps!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

View solution in original post

7 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: System Slowness with SC

Jump to solution

Hi @avilt,

Thank you for your post. May I know how you confirmed that Solidcore/Application Control was the root cause here?

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 8

Re: System Slowness with SC

Jump to solution

Hi @avilt,

Also, If Observe and enabled mode cause issues, Am I correct in assuming that Update mode and Disabled do not cause any slowness on the machine? This can help us choose a good path to isolate the issue and find the cause.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
Highlighted
Level 9
Report Inappropriate Content
Message 4 of 8

Re: System Slowness with SC

Jump to solution

Disable mode does not cause system slowness, I have not verified in update mode. Initiall systems were on ENS with SC. Hence concluded that SC is causing slowness.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 8

Re: System Slowness with SC

Jump to solution

Hi @avilt,

Thank you for your response. This is weird. I would first begin by isolating the feature responsible by disabling them one by one.

sadmin features list - This command should display the list of features and their corresponding states.

sadmin features disable featurename - Replace feauturename in this command with the name of the features you see in the list that is enabled and check for the issue. please repeat this process until we determine which feature is actually responsible.

With this information you can create a Support Request with us and we can work on this issue with you and investigate this further.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: System Slowness with SC

Jump to solution

Hi @avilt,

Apologies for the delay, I was handling multiple sessions here! Quite the Weekend! Can you kindly please check if this helps you?

https://kc.mcafee.com/corporate/index?page=content&id=KB81465

Mostly we come across this to be the reason, struck me when you mentioned ENS is also being used! I sincerely hope this helps!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

View solution in original post

Highlighted
Level 9
Report Inappropriate Content
Message 7 of 8

Re: System Slowness with SC

Jump to solution

MP features disabled on SC, now it's fine,

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 8

Re: System Slowness with SC

Jump to solution

That is good news.


Then you need to exclude the process from Memory Protection.

 

You can increase the log level to help find the process name 

 

Application/Change Control Loglevel:

Increase MAC loglevel component:
  1. sadmin recover (Password is required to unlock CLI).
  2. sadmin loglevel enable pst info.
  3. sadmin lockdown to restrict CLI access.
  4. Reproduce your issue with MP enabled.
Reset MAC loglevel component to default after you collected logs:
  1. sadmin recover (Password is required to unlock CLI).
  2. sadmin loglevel disable PST info.
  3. sadmin lockdown to restrict CLI access.
If you need help with this. Please contact support with the logs with Loglevel increased.
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community