cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
scarney
Level 9
Report Inappropriate Content
Message 1 of 2

Solidcore service coming up after multi-user.target : version 6.4.8 release 101.el7

Jump to solution

We went from version 6.3.0 release 503 where the service looks like:

# Copyright (C) 2018 McAfee, Inc.  All rights reserved.
[Unit]
Description=McAfee Solidifier service (scsrvc)
Before=multi-user.target
After=basic.target
DefaultDependencies=no

[Service]
Environment="SCSRVC_EXEC_CONTEXT=1"
ExecStart=/usr/local/mcafee/solidcore/scripts/scsrvc start
ExecStop=/usr/local/mcafee/solidcore/scripts/scsrvc stop
KillMode=none
RemainAfterExit=yes
TimeoutSec=0
Type=forking

[Install]
WantedBy=basic.target

Note the service is coming before multi-user.target.

At version 6.4.8 release 101.el7, the service looks like: 

# Copyright (C) 2019 McAfee, Inc.  All rights reserved.
[Unit]
Description=McAfee Solidifier service (scsrvc)
After=multi-user.target
DefaultDependencies=no

[Service]
#ExecStartPre=/bin/sleep 0
Environment="SCSRVC_EXEC_CONTEXT=1"
ExecStart=/usr/local/mcafee/solidcore/scripts/scsrvc start
ExecStop=/usr/local/mcafee/solidcore/scripts/scsrvc stop
KillMode=none
RemainAfterExit=yes
TimeoutSec=0
Type=forking

[Install]
WantedBy=multi-user.target

 Now we have a service we wrote that also comes up after multi-user.target.  Given the nature of systemd, scsrvc could come up after our service.  The problem is our service needs for some of its binaries to be solidified and one of it's binaries to be an updater.  If our service comes up for the mcafee service, it is going to break.  In fact, it did break.

So we can fix it by making our service come up after scsrvc.service.  However, we would like to know why was this change made?  What was being fixed?

1 Solution

Accepted Solutions
Pravas
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 2

Re: Solidcore service coming up after multi-user.target : version 6.4.8 release 101.el7

Jump to solution

Hi @scarney ,

I understand from your post that your service works if it runs after SolidCore.

We may not have it documented publicly about this change.

Could you please log a ticket with McAfee Support and we can verify it with developers.

Thanks.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

View solution in original post

1 Reply
Pravas
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 2

Re: Solidcore service coming up after multi-user.target : version 6.4.8 release 101.el7

Jump to solution

Hi @scarney ,

I understand from your post that your service works if it runs after SolidCore.

We may not have it documented publicly about this change.

Could you please log a ticket with McAfee Support and we can verify it with developers.

Thanks.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

View solution in original post

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community