cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 10
Report Inappropriate Content
Message 1 of 4

Solidcore installation issue

I had solidcore installed on of my server, for testing I had to remove it, and now I can't seem to get it install?

ePO show a successful install when I push it fro ePO, but app isn't there.

I checked the machine and it doesn't have any folder called solidcore in "Program files".

any idea?

Thanks!

3 Replies
Highlighted

Re: Solidcore installation issue

We had the same issue. The installer fails if the C:\Program Files\McAfee\Solidcore  (32-bit) or C:\Program Files (x86)\McAfee\Solidcore (64-bit) directory exists. Simply delete the directory and then reattempt your install and it should work fine.

HTH,

Mick

Level 8
Report Inappropriate Content
Message 3 of 4

Re: Solidcore installation issue

I think I got the steps initially from FAQ section of one of the install docs (?), but it looks like it's made it into a KB now, anyway:

https://kc.mcafee.com/corporate/index?page=content&id=KB75902

I've been doing a few extra steps, though, and finding and deleting the solidcore installer files under \Windows\downloaded installations\{<guid>} and/or the SOLIDCOR5000_WIN key under wow6432node might be what you need? The full list of extras I do are:

- I don't think I've ever needed to disable Access Protection, but may be needed in some cases

- I also delete:

    - <system drive>:\Windows\s3setup.log (just so next installation is

    - sometimes there's a <system drive>:\Windows\system32\drivers\swin1.sys file

    - <system drive>:\Windows\downloaded installations\{guid} directory

    - HKLM\SOFTWARE\Wow6432Node\Network Associates\ePolicy Orchestrator\ApplicationPlugins\SOLIDCOR5000_WIN key

    - HKLM\System\CurrentControlSet\services\swin

Edit...

The guid is from "HKLM\SOFTWARE\Classes\Installer\Products\4E9BD2348836F234A9BD168E87F25439\SourceList\LastUsedSource" (if it hasn't been deleted yet, of course), but I generally just go by the date/time stamp of the folder. (Can sometimes pay to remove the others mentioned under ....\SourceList\Net\1, \2, etc as well)

Highlighted
Level 10
Report Inappropriate Content
Message 4 of 4

Re: Solidcore installation issue

Thanks for the input, it worked.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community