cancel
Showing results for 
Search instead for 
Did you mean: 

Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

I am trying to install WinOF-2 2.10  software (MLNX_WinOF2-2_10_50010_All_x64.exe) which is the driver for a Mellanox ConnectX-5 NIC on a Windows Server 2016 host.  I am using Solidifier 8.1.0.179 and it is set to Update mode.

Uninstallation of an older driver rev fails unless I first put Solidifier into Disabled mode.  Similarly, I cannot install the new driver version unless Solidifier is in Disabled mode.

If I've installed the driver with Solidifier is in Disabled mode and I then transition Solidifier into Enabled mode, then Solidifier blocks the driver from executing.

Other driver installers don't have these installation problems and execution problems.  What kinds of things might cause one installer to work with Solidifier and another installer to fail to work with Solidifier?

7 Replies
McAfee Employee gnautiya
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

Hi,

To point out to the problem, we will require the debg logs from the system where this is happening.

Also in update mode, our memory protection works.

Hence you can try once by keeping this disable "mp" and "sau"

sadmin features disable mp

sadmin features disable sau

 

Regards

 

Was my reply helpful?
If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

Re: Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

If I understand correctly, you are asking me to configure for Update mode, then disable the two features you've noted, then execute the installer I am having trouble with.

I will try this.

Could you please provide guidance regarding how to collecting the debug logs that you are requesting?  Not sure where these are.

Re: Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

With the mp and sau features disabled, the driver installation has succeeded. Where can I find the debug logs that you are requesting?
McAfee Employee gnautiya
McAfee Employee
Report Inappropriate Content
Message 5 of 8

Re: Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

Hi,

Thanks for confirming this.

Logs you will find udner "c:\programdata\Mcafee\Solidcore\Logs" , also you can run on cmd "gatherinfo"

This will collecta ll the required details for debugging from your system.

 

Regards

Was my reply helpful?
If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?
McAfee Employee BEllis
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

8.1.0.179 had sau injected into all processes. can you please test with the latest 8.2.1.143 and see if issue happens. You can disable MP only if it helps then we can run debug logging for MP so we can see what needs to be bypassed

McAfee Support

Benjamin Ellis

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

I've installed the 8.2.1.143 software (is it correct that setup-win-8-10-2012-amd64-8.2.1.143.exe can be used with Windows Server 2016?)

Executing the installer "C:\Temp\MLNX_WinOF2-2_10_50010_All_x64\MLNX_WinOF2.msi" with Solidifier in Update mode results in an installation failure.  In attached .zip file, see Logs2-201904040132 and look for  installation event at about 1:32am

After disabling MP, I executed the installer again.  This time the installation succeeded.  See Logs3-201904040143 and look for installation event at about 1:43am

Well, I would attach a .zip file if I could.  Looks like I can't or it's in front of me and I'm not seeing it.  I've captured logs from C:\ProgramData\McAfee\Solidcore\Logs and have also executed gatherinfo.  Please let me know if there is a way to get these to you for review.

In your comment, you mention "run debug logging".  If that is something additional that I should try, please provide guidance.

Re: Software installer fails to execute with Solidifier 8.1.0.179 in Update mode

In the event that this is a useful data point, I also have an older Windows Server 2012 R2 host with Solidifier 7.0.1.275 installed.  I am able to execute the same Mellanox driver installer in Update Mode without issues.  MP is enabled on this host.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community