5 Replies Latest reply on Oct 3, 2013 4:00 PM by maxgb

    Restore backup on a replaced appliance

      Hi guys,


      I've followed the procedures described using the link below,


      Restore a backup file on a replaced appliance




      but received the following error:


      Job queued with id: 2

      Job progress: .

      Job finished.

      Coordinator responded:

      extracting files from backup failed. ERR ['.backup'-decoder]: failed to open input file (errno: 13 - 'Permission denied')



      I'm doing my backups using REST interface as described here: https://community.mcafee.com/message/305031#305031




      MWG 7.2


      Message was edited by: maxgb on 10/2/13 9:35:08 PM CDT
        • 1. Re: Restore backup on a replaced appliance

          You haven't given quite enough details to provide a water tight answer (e.g. are you using CLI or GUI,  at what point are you getting the error, what version of web gateway are you attempting to restore to?)


          However,  I'd suggest using the CLI method if you haven't already.  For good measure, once you scp the file to the box (using pscp.exe from the putty download page, or winscp if you like a GUI to transfer files from windows to unix) ...  run the command  as root on CLI:  


          chmod 644   nameofyourbackupfile     


          and try again.  


          The error suggests that whatever user the coordinator runs as... doesn't have read access to the backup file you scp'd over to the box.  

          chmod 644 will allow the owner to read/write it, but allow others and group to read it.   


          Beyond that, avail yourself of the excellent support folks who work the web gateway queue--I imagine they'll get you squared away quickly.


          on 10/3/13 2:49:28 AM CDT
          • 2. Re: Restore backup on a replaced appliance

            This is the CLI output.

            The permissions showed were used without success.

            The backup file was generated again using the method   

            /opt/mwg/bin/mwg-coordinator -B "file:in=ACTIVE"


            but again, the same error.


            -rw-rw-rw- 1 mwg mwg 554K Oct  3 15:48 2013-09-30_14-51-31-068_-0300.backup


            MWG 7.2 


            • 3. Re: Restore backup on a replaced appliance

              Hi maxgb -- I went through the steps in the document and used the same permissions as you showed above, but couldn't reproduce the problem.


              -What directory is the backup file placed in?

              -Can you send in a screenshot of the full command and error you get when running the command?


              It may also be worthwhile to open a support ticket so we can take a look at the backup file in case it is somehow related.



              • 4. Re: Restore backup on a replaced appliance

                Clearly the permissions problem isn't with the backup file then.    I like Darin's idea about what directory it's in that may prevent the script or whatever from unpacking the file there.     Definitely something worth chasingn down with support though. 

                • 5. Re: Restore backup on a replaced appliance

                  Hi dshock,


                  The directory was the problem!  :-)

                  I was using /root, that is not readable by the mwg user.


                  Moving to /opt/data/temp solved the problem.


                  Thanks guys!!