Dynamic Endpoint Security 1 - Getting Started

Version 20

     

    Assumptions

    In this rest of this guide we will walk step-by-step through deployment and configuration of a comprehensive Dynamic Endpoint solution.  Before we start, we wil make some assumptions about your environment.

    1. We will assume that McAfee ePolicy Orchestrator (ePO) is deployed and operational in your environment.
    2. We will assume that the McAfee Agent (MA) is deployed to the systems you would like to protect.

    Please see below for preferred versions of ePO and MA.  For guidance in installing and deploying ePO, please see ePolicy Orchestrator Expert Center.

     

    Preferred Versions

    Given the variety of moving parts in the McAfee Dynamic Endpoint Security solution, it is helpful to ensure that you are deploying modules that are known to be compatible with each other.  The tables below document the preferred software versions at this time.  Please consult product documentation for information on compatibility for versions not listed here.

     

    The Dynamic Endpoint solution is deployed on top of the "Basic Endpoint" solution.  There are two options for Basic Endpoint:

    1. McAfee VirusScan 8.8 (VSE)
    2. McAfee Endpoint Security 10.1 (ENS)

    Required modules for your environment will change slightly depending on whether you are choosing VSE-based or ENS-based deployment.

     

    Initial Prerequisites

    Product

    Preferred Version

    ePolicy Orchestrator

    5.3.1

    McAfee Agent

    5.0.2.333

     

    Basic Endpoint

    Product

    Preferred Version

    (VSE Deployment)

    Preferred Version

    (ENS Deployment)

    VirusScan Enterprise

    8.8.0.1528

    N/A

    VirusScan Management Extension

    8.8.0.448

    N/A

    VirusScan Reports Extension

    1.2.0.272

    N/A

    McAfee Endpoint Security 10.1 Bundle

    N/A

    10.1.0.649

    Endpoint Security Threat Prevention HF1111757

     

    N/A

    10.1.0.1111757

    Endpoint Security Web Control HF1112734

    N/A

    10.1.0. 1112734

     

    Data Exchange Layer and Threat Intelligence Exchange

    Product

    Preferred Version

    (VSE Deployment)

    Preferred Version

    (ENS Deployment)

    DXL Client

    2.0.1.162

    2.0.1.162

    DXL ePO Client Extension

    2.0.1.140

    2.0.1.140

    DXL Broker Management Extension

    2.0.1.140

    2.0.1.140

    DXL Client Management Extension

    2.0.1.140

    2.0.1.140

    Threat Intelligence Exchange (TIE) Server

    1.2.1.236

    1.2.1.236

    TIE Server Management Extension

    1.2.1.236

    1.2.1.236

    TIE Module Management Extension

    1.0.1.140

    10.1.0.129

    Threat Intelligence Exchange Module for VirusScan Enterprise

    1.0.1.140

    N/A

    Threat Intelligence for ENS

    N/A10.1.1.101

     

    Active Response

    Product

    Preferred Version

    Active Response

    1.1.0.161

     

    Advanced Threat Defense

    Product

    Required Version

    Advanced Threat Defense

    3.4.8.193.54309

     

    Now that you have reviewed the prerequisites and software versions we'll install, please visit Dynamic Endpoint Security 2 - Basic Endpoint.