Hi Gurus!

 

It appears that there is a bug in Chrome 47 causing problems with NTLM Authentication.

 

In the mean time it might be best to prevent it from being installed. A fix was mentioned to be ready by Friday, but I'm not clear if that's definitive.

 

Details on the bug can be found here:

Issue 544255 - chromium - Chrome asks for authentication on http sites on squid - An open-source project to help move…

 

A workaround has been discovered! (Dec 4th)

The issue has to do with Chrome receiving the HTTP response, and the HTTP response is too big for it's buffer. So if we reduce the size of the response, Chrome will behave in a better fashion.

 

To reduce the size of the response, we can change the MWG block page which is used for authentication. To do this, navigate to Policy > Settings, and click edit for any of the block templates. On the Template Editor screen, find the "Authentication Required" block page template and remove the contents of this blockpage (at least for now).

 

template.jpg change.jpg

 

Update Dec 8th - Create an empty collection

Some customers reported that the above workaround did not help. If you are using your own custom template collection, we will need to create an empty template collection. This can be done in four steps:

 

1. Create an "empty" template collection by clicking add next to the Collection dropdown, instead of OK and Edit:

 

2015-12-08_095821.jpg

 

 

2. Verify that the "empty" collection is selected:

 

2015-12-08_095952.jpg

 

3. Create an empty "Authentication Required" Template, and click OK:

 

2015-12-08_100331.jpg

 

4. Add a single space to the index template:

 

2015-12-08_101136.jpg

 

 

The only other workarounds would be to disable authentication or enable Kerberos authentication. Here is a link to the guide on setting up Kerberos: Web Gateway: Configuring Kerberos (simplified guide)

 

Best Regards,

Jon