https://kc.mcafee.com/corporate/index?page=content&id=KB77361

 

How to enable MEG 7.x RapidRetry

 

Problem

When sending mass emails to various external domain like domains hosted by Gmail, MX Logic, or other vendors like Yahoo/Sbcglobal through the McAfee Email Gateway, the emails are queued with the following reasons:

 

452 too many recipients.

 

451-4.3.0 Multiple destination domains per transaction is unsupported

 

Cause

New functionality was added in MEG 7.0 Patch 3 (and included in all subsequent releases)  to enable RapidRetry.

 

MEG delivers emails based on the IP address(es) resolved (using MX lookup, domain relay config etc.) for the destination domains;

If there is an email with multi-domain recipients where MX records (for e.g.) of two or more domains point to the same destination server, MEG would deliver the matching ones over the same transaction as per 4.5.4.1. Sending Strategy of RFC5321.

 

4.5.4.1. Sending Strategy

 

   When a mail message is to be delivered to multiple recipients, and

   the SMTP server to which a copy of the message is to be sent is the

   same for multiple recipients, then only one copy of the message

   SHOULD be transmitted.  That is, the SMTP client SHOULD use the

   command sequence: MAIL, RCPT, RCPT, ..., RCPT, DATA instead of the

   sequence: MAIL, RCPT, DATA, ..., MAIL, RCPT, DATA.  However, if there

   are very many addresses, a limit on the number of RCPT commands per

   MAIL command MAY be imposed.  This efficiency feature SHOULD be

   implemented.

 

RapidRetry was designed to address such issues.

 

Solution 1

This issue is resolved in Email Gateway 7.0.3 or higher, which is available by logging in to the ServicePortal at: https://support.mcafee.com/downloads.

 

Patches are cumulative; therefore, McAfee recommends that you install the latest one. 

 

To review the Release Notes for this patch, see PD24438.

To review Known Issues, see KB76745.

 

To enable this functionality, install patch 3 or later and then edit the config file as follows:

 

Open the Appliance management console.

Click System, System Administration, Backup and Restore.

Save a copy of the configuration file. 

 

NOTE: For full instructions on how to back up and edit an Appliance configuration file, see KB56323.

 

Create a new directory on your client.

Extract smtp-retryer-config.xml from the saved configuration file into the new directory and create a backup copy of this file.

 

 

NOTE: Ensure that you do not extract the full zip file, only the XML to be edited. Extracting the full configuration can cause corruption in the configuration.

 

Open the smtp-retryer-config.xml file with Notepad or another plain text editor.

Enable and configure RapidEnabled:

 

Locate the following entry: RapidEnabled="0"

Change 0 to 1.

 

For example:

RapidEnabled="1"

 

Add the SMTP error codes to be RapidRetried.

 

For example:

 

<RapidErrorCodes>

        <Attr name="0" value="450"/>

        <Attr name="1" value="451"/>

        <Attr name="2" value="452"/>

      </RapidErrorCodes>

Save smtp-retryer-config.xml. If prompted, select .txt and ignore any warnings about removing the formatting.

 

IMPORTANT: If you save smtp-config.xml in a rich text format, the data will be corrupted.

 

Update the configuration zip file with the modified smtp-retryer-config.xml. Use Winzip or an equivalent application that works with long filenames.

 

NOTE: If you use Winzip, ensure that the full path info option is not enabled. 

 

Restore the modified zip file to the Appliance via the Backup and Restore page.

Click Apply Changes.